Thursday, June 27, 2013

Whine with my Wine






We have been waiting.

And waiting, and waiting and waiting.

Back in December of 2011, we were told, "a few months, you'll have the new pods!"

Liars.

First they shipped to NEW customers. Now they are shipping to existing customers, finally. But it seems as though everyone on my feed has them and we still don't. I'm trying not to be bitter, because we love the Omnipod, but dammit, I just want these now for Adam's sake!

Mama's going to have to make some calls and be bitchy tomorrow. Sigh.

9 comments:

  1. Our pump went out the other day, but still, they are going to send us an old version replacement! Consider that very annoying. But, interesting experiment to be back on shots -- and Lantus -- for a couple days.

    ReplyDelete
  2. But considering the investment I still have tied up in the pods in my closet, I guess going thru them will still be worth my money.

    ReplyDelete
  3. I wish I could give you ours! We received the new without notice and while I am very excited for the smaller pods, it sounds like there are some kinks to be worked out. So I am afraid to start them, plus we have about 3 boxes of old to work our way through first.

    ReplyDelete
  4. We are right there with you Stephanie. Our PDM died about a month ago and they denied my request of switching to the new unit and mailed us the "old" PDM. Emerson starts school this year so I'm hoping we have it before we train the school nurse.

    ReplyDelete
  5. We are still waiting on the new pods also!!

    ReplyDelete
  6. Wow in 2011, that was two years ago! That's a longtime to wait!!!

    ReplyDelete
  7. How do I know if I got the new ones? Joe is starting on the POD on Monday?

    ReplyDelete